Results 1 to 12 of 12

Thread: Aye

  1. #1
    Join Date
    Oct 2002
    Location
    Trinidad
    Posts
    52

    Has anyone ever seen this error?

    I'm running SQL 2000, no Service pack on a W2k server SP4.0. I have a number of jobs that run fine when execued from the DTS package, but when these packages are scheduled as a SQl Job, they fail when executed with the following error

    "runtime error R6025 - pure virtual function call"

    Any assistance would be greatly appreciated.

    Thanks
    Last edited by Katyan; 10-14-2005 at 12:40 PM.

  2. #2
    Join Date
    Nov 2002
    Location
    New Jersey, USA
    Posts
    3,922
    Sounds like your SQL Agent service account does not have privilege to do tasks in the DTS. What does the DTS do?.

  3. #3
    Join Date
    Sep 2002
    Posts
    5,938
    If package accesses data from remote data source, should start sql agent service with domain account that has proper permission on remote data source.

  4. #4
    Join Date
    Oct 2002
    Location
    Trinidad
    Posts
    52
    The DTS package is copying two tables from an AS400. These are the steps I take. I select my database and choose import data. I follow all the steps necessary to import the data, at the end, I schedule, save and run the package from the import wizard. All of this is completed without error.. however the scheduled job will fail with the above error when executed, but the DTS wil run fine.

  5. #5
    Join Date
    Oct 2002
    Location
    Trinidad
    Posts
    52
    I have similar packages that compy from the AS400 that work fine. The only difference with these failing jobs seems to be that they attempt to import more than 1 table at the same time.
    Last edited by Katyan; 10-14-2005 at 12:58 PM.

  6. #6
    Join Date
    Sep 2002
    Posts
    5,938
    Possible to schedule them to run at different time?

  7. #7
    Join Date
    Oct 2002
    Location
    Trinidad
    Posts
    52
    That would be a possible workaround. . . but I really want to know what's causing this problem.

  8. #8
    Join Date
    Sep 2002
    Posts
    5,938
    Then you need trace that on DB2/400.

  9. #9
    Join Date
    Oct 2002
    Location
    Trinidad
    Posts
    52
    I installed service pack 3a for SQL server 2000 and the error changed to the include the following "process exit code 1073741819" with the jobs still failing. I then installed Sp4 and now the jobs just say executing, but do not run. When I check the activity logs and locks, nothing pertaining to the job is being displayed, so it seems like athough the job is displayed as executing nothing is actually happening. This is very strange. Any more ideas.

  10. #10
    Join Date
    Sep 2002
    Posts
    5,938
    How does sql talk to db2/400? Did you install client express on sql server? Which version?

  11. #11
    Join Date
    Oct 2002
    Location
    Trinidad
    Posts
    52
    SQL connects to the AS/400 using a driver called StarSql, this comes bundled with SNA server. So I have installed the Starsql driver on the server in question, by installing SNA 3.0 Client and only installing the StarSql odbc driver.

  12. #12
    Join Date
    Sep 2002
    Posts
    5,938
    Not sure for that, I use as/400 client access express and have no problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •