dcsimg
Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

Thread: SQL2K Bind Failed

  1. #16
    Join Date
    Apr 2003
    Posts
    12

    Arrow

    good point, Jim. i checked it out, but the only entry in the file is the correct one - 127.0.0.1. also, the logs show that SQL Server is binding to all IP's correctly. the only problem is that it is doing it twice - on 2 different ports (currently 1433 and 1174). is there anywhere else SQL Server would look for this information on startup?

  2. #17
    Join Date
    Jun 2004
    Location
    Berkshire, UK
    Posts
    8
    Just to clarify something, in a previous post you said it was dual homed, so it has two ethernets ports, so it will try and bind to both. I presume both have different static IPs configured and they are in different subnets. If so, it might be interesting to see what happens when you disable one of the network cards (maybe try each one in turn)? Does it still try and bind twice, with just one card available?

  3. #18
    Join Date
    Sep 2002
    Posts
    5,938
    If you let sql instance use dynamic port, it shouldn't use 1433 then. Double check registry key for port number used.

  4. #19
    Join Date
    Apr 2003
    Posts
    12

    Arrow

    can't disable the intranet because it's AD/DNS for the domain. disabling the internet doesn't affect the dual-port problem, just fewer IP's to bind to.
    the registry appears to be working fine. i can change the port and view the change immediately. 1433 is just the last number that i tried - it was a registry hack just to see what would happen. i noted that the SuperSocketNetLib\ProtocolList value only shows "tcp" once. is there another place in the registry where SQL would look for this value?

  5. #20
    Join Date
    Sep 2002
    Posts
    5,938
    Not as I aware of. Did you see any value in tcpdynamicports?

  6. #21
    Join Date
    Apr 2003
    Posts
    12

    Arrow

    i don't recall what was there originally - i think it was empty, but i did change it during troubleshooting, still with no effect.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •